ASRock.com Homepage
Forum Home Forum Home > Technical Support > Intel Motherboards
  New Posts New Posts RSS Feed - TPM2-S module supported off on Z97E-ITX/ac
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

TPM2-S module supported off on Z97E-ITX/ac

 Post Reply Post Reply Page  12>
Author
Message
szalay.istvan1 View Drop Down
Newbie
Newbie
Avatar

Joined: 18 Nov 2017
Location: Hungary
Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote szalay.istvan1 Quote  Post ReplyReply Direct Link To This Post Topic: TPM2-S module supported off on Z97E-ITX/ac
    Posted: 18 Nov 2017 at 6:19pm
Hi, 
I bought an ASRock TPM2-S Nuvoton NPCT650/TCG Compliance TPM Module from Bestmarkt on the internet. I installed the TPM module in my ASRock Z97E-ITX/ac motherboard with bios v 2.10 (this is the latest). In the manual doesn't wroted that mobo not compatible with TPM2-S (TPM V2.0) module! 

In the UEFI setup, under Advanced\Trusted Computing, I have enabled:
Auto Detect Security Device
Security Device Support

but the Current Status Information is Support Turned Off remains.

When I run tpm.msc, Windows says that the Compatible Trusted Platform Module (TPM) cannot be found on this computer. Verify that this computer has a 1.2 TPM or later and it is turned on in the BIOS.

I resetted the BIOS, reinstalled the module, enabled the TPM module in the gpedit.msc, but doesn't worked.

I submitted a technical support request today with the ASRock website too.

Any thoughts or suggestions would be appreciated.

Thanks,

Istvan
ASRock is the best!
Back to Top
ASRock_TSD View Drop Down
ASRock_Official
ASRock_Official


Joined: 20 Mar 2015
Status: Offline
Points: 7272
Post Options Post Options   Thanks (1) Thanks(1)   Quote ASRock_TSD Quote  Post ReplyReply Direct Link To This Post Posted: 21 Nov 2017 at 10:28am

Dear Szalay.istvan1,

 

Thank you for choosing ASRock.

 

Regarding your case, please download the BIOS P2.10E from below link to support TPM2.0 module.

And update it by instant flash.

https://mega.nz/#!I4520R5Y!S8avSF-1Ct4_nNad5dvcocYZx2tV8fHk1k6mi9qNtPk

 

Thank you!

Yours truly,

ASRock TSD

Back to Top
szalay.istvan1 View Drop Down
Newbie
Newbie
Avatar

Joined: 18 Nov 2017
Location: Hungary
Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote szalay.istvan1 Quote  Post ReplyReply Direct Link To This Post Posted: 21 Nov 2017 at 11:10pm
Thanx for the fast work. You support is great!

Istvan Szalay
ASRock is the best!
Back to Top
descent7 View Drop Down
Newbie
Newbie
Avatar

Joined: 30 Nov 2017
Location: Hungary
Status: Offline
Points: 21
Post Options Post Options   Thanks (0) Thanks(0)   Quote descent7 Quote  Post ReplyReply Direct Link To This Post Posted: 24 Mar 2018 at 12:14am
Dear Asrock TSD!

I flashed on my Z97E-ITX/AC mobo the latest P2.20 firmware for security. So far I used your TPM2-S (V 2.0) module with P2.10E bios (modified by you) and now the module is useless again. Could you modify the latest P2.20 firmware to be compatible with TPM2-S module? 

Thanks in advance

Istvan Szalay
Back to Top
descent7 View Drop Down
Newbie
Newbie
Avatar

Joined: 30 Nov 2017
Location: Hungary
Status: Offline
Points: 21
Post Options Post Options   Thanks (0) Thanks(0)   Quote descent7 Quote  Post ReplyReply Direct Link To This Post Posted: 29 Mar 2018 at 5:03am
Asrock TSD  has released for Z97E-ITX/AC BIOS P2.20A to add TPM 2.0 support.
If you need download the BIOS from below link.



Asrock. thanks once again!

This is THE SUPPORT!


Edited by descent7 - 29 Mar 2018 at 5:05am
Back to Top
nilezon View Drop Down
Newbie
Newbie


Joined: 30 Apr 2018
Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote nilezon Quote  Post ReplyReply Direct Link To This Post Posted: 30 Apr 2018 at 2:52am
Originally posted by descent7 descent7 wrote:

Asrock TSD  has released for Z97E-ITX/AC BIOS P2.20A to add TPM 2.0 support.
If you need download the BIOS from below link.



Asrock. thanks once again!

This is THE SUPPORT!


Thank you, but link seem to be dead now. Any mirrors?
Back to Top
descent7 View Drop Down
Newbie
Newbie
Avatar

Joined: 30 Nov 2017
Location: Hungary
Status: Offline
Points: 21
Post Options Post Options   Thanks (0) Thanks(0)   Quote descent7 Quote  Post ReplyReply Direct Link To This Post Posted: 30 Apr 2018 at 6:17pm
https://mega.nz/#!pAFyXYoD!zWH6Cs6xUkZoRWv81-DBRHdGIhw8f1YVU2b6cXjnGPE 
 
Here you are. Copy and paste.


Edited by descent7 - 30 Apr 2018 at 6:21pm
Back to Top
nilezon View Drop Down
Newbie
Newbie


Joined: 30 Apr 2018
Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote nilezon Quote  Post ReplyReply Direct Link To This Post Posted: 01 May 2018 at 6:02pm
Thank you!
Back to Top
bsexton View Drop Down
Newbie
Newbie


Joined: 28 Jul 2018
Location: Bloomfield, IN
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote bsexton Quote  Post ReplyReply Direct Link To This Post Posted: 28 Jul 2018 at 5:47am
After installing the TPM2-S and firmware P2.20A on my Z97E-ITX/ac, I have noticed that it boots MUCH slower.
There is nothing fast about fast boot. I cleared the bios and re-enabled the TPM module but still have the same slow results. Once it starts to boot Windows, it is fine, but it is painfully slow getting there.
 
Has anyone else experienced this issue?
Back to Top
TrutY View Drop Down
Newbie
Newbie
Avatar

Joined: 25 Jul 2018
Location: Cro
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote TrutY Quote  Post ReplyReply Direct Link To This Post Posted: 12 Aug 2018 at 10:16pm
I have the exactly the same problem. First, I thought it will not boot at all. But after cca.60sec I get the boot screen, then another 60sec for windows too start booting after that everything seems fine.
Back to Top
 Post Reply Post Reply Page  12>
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.047 seconds.