ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - AB350 Gaming-ITX/ac - BIOS 4.40 bricked it
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

AB350 Gaming-ITX/ac - BIOS 4.40 bricked it

 Post Reply Post Reply Page  <123
Author
Message
Dibdidu View Drop Down
Newbie
Newbie


Joined: 17 Jan 2018
Status: Offline
Points: 11
Post Options Post Options   Thanks (0) Thanks(0)   Quote Dibdidu Quote  Post ReplyReply Direct Link To This Post Posted: 19 Jan 2018 at 5:15pm
Heyho, i got my new 3.40 bios chip.
It isn't working...
Screen is black, no led for keyboard and system is restarting all the time.

-> RMA.
Back to Top
wussery View Drop Down
Newbie
Newbie


Joined: 15 Nov 2017
Status: Offline
Points: 56
Post Options Post Options   Thanks (0) Thanks(0)   Quote wussery Quote  Post ReplyReply Direct Link To This Post Posted: 24 Jan 2018 at 3:19am
What was Bios 4.40 supposed to fix?
MOBO: ASRock AB350 Gaming-ITX/ac
CPU: Ryzen 5 1600
RAM: G.SKILL TridentZ Series 16GB DDR4 3200
GPU: EVGA GeForce GTX 1060 SC
PSU: EVGA 750 B3
Cooler: Cryorig C7
Boot Disk: SAMSUNG 850 PRO 256GB SSD
Back to Top
Dibdidu View Drop Down
Newbie
Newbie


Joined: 17 Jan 2018
Status: Offline
Points: 11
Post Options Post Options   Thanks (0) Thanks(0)   Quote Dibdidu Quote  Post ReplyReply Direct Link To This Post Posted: 24 Jan 2018 at 4:09am
Nothing, but it adds support for new cpu/apu.
I will get an Ryzen 5 2400G soon.
But it seems it stops supporting 9800E^^
Back to Top
Matush View Drop Down
Newbie
Newbie


Joined: 23 Feb 2018
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote Matush Quote  Post ReplyReply Direct Link To This Post Posted: 23 Feb 2018 at 6:27am
The same issue here. Got hte AB350 ITX board, put in mine old 1600 to get the board SW up to 4.4 (Raven Ridge supported BIOS), after the middle FW 3.6 upgrade all good, after going from 3.6 to 4.4  system is booting to the first BIOS window (F2 DEL to BIOS F6 INSTAN FLASH) but only for about a second then restarts and over and over forever. Tried everything mentioned here, clear CMOS, etc, but the same .... Going to return the board back to asrock as this is nonsense.
Back to Top
thiagohpb View Drop Down
Newbie
Newbie
Avatar

Joined: 18 Mar 2018
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote thiagohpb Quote  Post ReplyReply Direct Link To This Post Posted: 18 Mar 2018 at 1:26pm
I just bought a AB350 ITX/ac MB, on my first day using it, I've tried to update BIOS because the CPU temperature was 127ÂșC constantly... even just after starting up.

The original BIOS version was 4.40, I've found on the MB website a version 4.50, saying: Before updating this BIOS, please update BIOS to P3.60 firstly.

So I downloaded the 3.60 and 4.50 versions, put on the pendrive just formated in FAT32, I did the first update to 3.60 version, It was completed 100%, ask to press enter to restart the system, after that my screen keeps off and the MB stays restarting... I have no screen.

I tried to reset the CMOS but no way... It keeps the same.

My CPU is a Ryzen 5 2400G.

Does anybody have an idea to fix that?
Back to Top
stree View Drop Down
Groupie
Groupie
Avatar

Joined: 17 Dec 2015
Location: Lincolnshire
Status: Offline
Points: 264
Post Options Post Options   Thanks (0) Thanks(0)   Quote stree Quote  Post ReplyReply Direct Link To This Post Posted: 18 Mar 2018 at 2:21pm
Because now you need a pre raven ridge APU, such as the AMD boot kit.
Why? because you backdated your BIOS to 3.6 bridge BIOS when there was absolutely no need to.
You ( usually)work your way through the BIOS updates in a linear fashion, and there may be what is called a Bridge BIOS...on this MB version 3.6 is such a Bridge BIOS....once you have it it allows you to then download a Raven Ridge compatible BIOS.  Such as 4.40 (yes, it is very buggy)
You were already at that stage......and because you were at that stage you had no further need to use a Bridge BIOS from earlier in the series. You could and shold have gone straight to 4.50.
You are not the first to fall for this, perhaps it could be stressed more in the literature.
But you do not have Bricked MB, just one with a BIOS not ready for Raven Ridge, so beg borrow or steal an APU that will allow you to boot, install 4.50 and put it down to experience.
ASRock X370-ITX BIOS 4.50
R5 2600    Cryorig C7
EVGA GTX 950 75w
2x8GB Ballistix Sport LT 2933
960Evo M.2 256GB, Firecuda 1TB
Win 10 Pro 64 1803
G-Unique Archdaemon 300 Watt
Lian-li Q21B
Back to Top
 Post Reply Post Reply Page  <123
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.176 seconds.